Browsers
Updated over a week ago

We recommend using Google Chrome or Firefox as your browser.

While the Deeper Signals Platform will still work on other browsers, these browsers are not as optimized to process modern web development standards, so you may encounter issues with the software using them that you wouldn’t with Google Chrome or Firefox.

We do not support Microsoft Internet Explorer for security and stability reasons.

Did this answer your question?